WordPress 2.3 arrive

Depuis la sortie de WordPress 2.2, plusieurs versions correctives sont sorties, tant pour la branche 2.0.x de WordPress (soutenue pendant quelques années encore) que pour la dernière branche 2.2.x. Dans les faits, les dernières versions stables et recommandées pour chaque branches sont donc la 2.0.11 et le 2.2.3.

Ces version ont toutes été traduites avec soin et rapidité par Amaury Balmer, responsable technique de l’association WordPress-fr – et qui en tant qu’étudiant en freelance dispose de beaucoup plus de temps libre que moi a l’avantage d’avoir un client Subversion qui marche ;)
Myriam Faulkner, qui avait fait partie de l’équipe de traduction initiale, à également mit la main à la pâte.

Vous trouverez le résultat de leur travail de traduction et correction dans les archives complètes et les fichiers attenants :
– WordPress 2.0.11 en français : archive ZIP, fichier PO utf-8 (iso-8859-1), fichier MO utf-8 (iso-8859-1).
– WordPress 2.2.3 en français : archive ZIP, fichier PO utf-8 (iso-8859-1), fichier MO utf-8 (iso-8859-1).

MISE A JOUR: retrouvez les dernières versions recommandées directement sur fr.wordpress.org.

Ces versions apportant des corrections parfois cruciales au niveau de la sécurité, je ne saurais que vous recommander de mettre votre blog à jour…

Mais un autre évènement approche : la sortie très prochaine de WordPress 2.3. Celle-ci profite, comme pour toute version majeure, de nouveautés assez conséquentes, les plus visibles étant l’intégration directe des tags dans l’interface de WordPress, sans devoir installer un plug-in, ou encore un système d’annonce de disponibilité de nouvelles versions pour les plugins. Mais les changements les plus importants se font en coulisses, et profiteront aux développeurs qui conçoivent de plugins et utilisent WordPress comme plate-forme de développement Web.

Les apports sont cependant tels que des articles arrivent pour préparer les utilisateurs au passage – ou non – à WordPress 2.3. En effet, la base de données de WordPress a été largement reprise en main, tout comme l’API interne, ce qui peut casser des blogs/sites reposants sur des plugins trop anciens (par exemple, ceux qui font des appels directs sur les tables categories, link2cat, ou post2cat) ou des fonctions internes modifiées.

Matt a écrit à ce sujet récemment, dans son court article « Preparing for 2.3″ : « Faites impérativement une sauvegarde de vos fichiers ET de votre base de données, vérifiez/mettez à jour tous vos plugins« , etc. Amaury, encore lui, a créé un fil de discussion sur le forum de WordPress Francophone, et les développeurs pourront goûter à ses explication sur la nouvelle taxinomie de WordPress.

Donc, si vous comptez passer directement à WordPress 2.3 plutôt que de mettre à jour vers la version 2.2.3, réfléchissez-y à deux fois pour le moment. Tout n’est pas forcément prêt avant la version finale :) Patience !